ProSphere - Unable to login after initial deployment
Hello -
I just deployed 1.6 in my lab and the vApp comes up fine. When I hit the main page to log in using appadmin/Changeme1! it won't accept the credentials. I also tried them on the console of the SRM (app) VM and it tells me the credentials are invalid.
I powered the vApp off and back on with no success. I also verified that IE has TLS 1.0 enabled.
Figured it out. The problem was I included underscores in the FQDNs of the individual components of the Prosphere vApp. The error I would get was basically:
The login failed due to a the service not responding or the incorrect role was assigned. Please contact EMC support for help.
I deleted the vApp and re-deployed without underscores and it worked fine. I did see where the it was not recommended to use underscores in the deployment guide. It would be nice if the guide was more definitive on not using underscores.
So - if you get a login error and you ARE SURE you are using the right username and password - you might make sure you do not use underscores in the hostnames of the vApp components.
Not sure why ProSphere documentation does not give a warning about hostnames. But it is a standard naming convention that underscore is not permitted. The following quote is from RFC952, DOD INTERNET HOST TABLE SPECIFICATION
ASSUMPTIONS
1. A "name" (Net, Host, Gateway, or Domain name) is a text string up to 24 characters drawn from the alphabet (A-Z), digits (0-9), minus sign (-), and period (.). Note that periods are only allowed when they serve to delimit components of "domain style names". (See RFC-921, "Domain Name System Implementation Schedule", for background). No blank or space characters are permitted as part of a name. No distinction is made between upper and lower case. The first character must be an alpha character. The last character must not be a minus sign or period.
RFC1123 relaxed the first character rule to permit an alpha or numeric character, and mandated you must handle 63 character length hostnames, and you "should" handle 255 character hostnames.
jcingle1
16 Posts
840
0
Posted August 15th, 2012 08:00
Figured it out. The problem was I included underscores in the FQDNs of the individual components of the Prosphere vApp. The error I would get was basically:
The login failed due to a the service not responding or the incorrect role was assigned. Please contact EMC support for help.
I deleted the vApp and re-deployed without underscores and it worked fine. I did see where the it was not recommended to use underscores in the deployment guide. It would be nice if the guide was more definitive on not using underscores.
So - if you get a login error and you ARE SURE you are using the right username and password - you might make sure you do not use underscores in the hostnames of the vApp components.